Author Topic: Waggster BLTouch V1.0  (Read 7978 times)

jakekooser

  • Newbie
  • *
  • Posts: 2
    • View Profile
Re: Waggster BLTouch V1.0
« Reply #15 on: December 13, 2019, 09:54:19 PM »
Hi there,

Just wanted to say thank you for an outstanding mod.  I was able to get mine set up according to the .pdf file but it seems as though my Z axis might be creeping a bit due to heat cycles.  I loaded the Marlin 2.0 BL Touch.hex file and I am able to do the z-offset but when I go to do my first print, I don't have the 'baby steps' option available anywhere on the touch screen.  I am using Octoprint, could that be the issue?

Thanks

Waggster

  • Administrator
  • Full Member
  • *****
  • Posts: 175
    • View Profile
Re: Waggster BLTouch V1.0
« Reply #16 on: December 14, 2019, 06:25:47 AM »
Hi, thanks for the comments.  Yes, you are correct in that octoprint talks directly to the mainboard and bypasses the touchscreen so no options will show. I would do a print from the usb via the touchscreen just to tune your z-offset then swap back to your octoprint pi. :-)

Steve

jakekooser

  • Newbie
  • *
  • Posts: 2
    • View Profile
Re: Waggster BLTouch V1.0
« Reply #17 on: December 14, 2019, 09:34:17 AM »
That did the trick, thank you!

TPJensen

  • Newbie
  • *
  • Posts: 1
    • View Profile
Re: Waggster BLTouch V1.0
« Reply #18 on: January 25, 2020, 06:50:04 PM »
Thanks for this great guide  :) 8)

I have made the update to the Sidewinder x1 and got it to work after some work, it was because my brown wires was backwards in the plug.

But I have 1 problem I cant solved so I can use the printer... When I start a print it level out bed no problems it start the print but when the part cooler start the bltouch activate on off on off and dont stop before fan if off or I stop the print and reset printer....

It also just happen when I manuel start the fan..

The problem is found and how wierd it sounds is fan the part cooler fan. Did put another one on and now it works fine.... the old one on again and problem again so the Fan

UPDATE

The Problem is still there on stock fan size 4020 But found out the if the fan runs MAX then no problem but under BLtouch act up
IF I use a 5015 fan instead then there is no problem on any speed...

Columbian

  • Newbie
  • *
  • Posts: 1
    • View Profile
Re: Waggster BLTouch V1.0
« Reply #19 on: February 02, 2020, 03:42:56 PM »
Hi all. I'm brand new to 3D printing. I am waiting for my Sidewinder X1 to arrive with the bltouch, hopefully tomorrow. I am wondering if there are any tips using version 4 of the Sidewinder. It looks like there might be some issues.

Waggster

  • Administrator
  • Full Member
  • *****
  • Posts: 175
    • View Profile
Re: Waggster BLTouch V1.0
« Reply #20 on: February 03, 2020, 12:32:39 PM »
Generally, the X-1 prints superb out of the box once you have levelled the bed. I would get a few prints done and maybe if you then think it's worth fitting a BL Touch then give it a go.. I wouldn't just jump straight in as sometimes your bed is that flat you don't need to. 

Any problems just ask away and I'll do my best to help you.

Happy printing :-)

Steve

Flipit

  • Newbie
  • *
  • Posts: 1
    • View Profile
Re: Waggster BLTouch V1.0
« Reply #21 on: April 24, 2020, 11:54:34 PM »
Great work.  This is an excellent tutorial.

I have just encountered one problem with setting the z offset with V1.5.  When I hit the start z offset button,  the extruder crashes into the bed.  I have done the setup multiple times using the disc to set the bltouch 4mm higher than the nozzle, but I get the same results. I can't see where I am going wrong.

I have kindof got it going now with the probe being at the same level as the nozzle,  but it of course catches the prints,  so not viable.

The probe is showing no errors (it's a 3dtouch).


Waggster

  • Administrator
  • Full Member
  • *****
  • Posts: 175
    • View Profile
Re: Waggster BLTouch V1.0
« Reply #22 on: April 25, 2020, 01:35:20 AM »
hmm it sounds like the BL Touch isn't triggering.  I would try flipping one of the 3 pin plugs around.. also make sure you have your signal wire attached to the Z max signal pin. If you can take photos that may help?

jonmcclay

  • Newbie
  • *
  • Posts: 1
    • View Profile
Re: Waggster BLTouch V1.0
« Reply #23 on: June 13, 2020, 09:59:56 AM »
I ordered this BLtouch https://www.amazon.com/gp/product/B07GVCX74T from Amazon

After following the guide I discovered that the device needs a male-male connector for the LED connection. One user at the Facebook Group for Artillery Modifications recommended this part:
https://www.amazon.com/gp/product/B00U8OCENY

The fans need longer screws as well, I bought this kit since I will probably be needing them in the future. Also the kit includes the right screw for the vertical adjustment of the BLtouch:
https://www.amazon.com/gp/product/B07H4MG7TC
« Last Edit: June 15, 2020, 02:23:50 AM by CdRsKuLL »

Allcrafter

  • Newbie
  • *
  • Posts: 1
    • View Profile
Re: Waggster BLTouch V1.0
« Reply #24 on: December 18, 2020, 11:14:21 AM »
If I click on pause my extruder will reverse and push filament out instead of in.
Could you fix that?
Also now the Motors are louder.

DocEmmetBrown

  • Newbie
  • *
  • Posts: 3
    • View Profile
Re: Waggster BLTouch V1.0
« Reply #25 on: February 14, 2021, 04:54:18 AM »
Hello,
to all in this forum. I am new here. Have upgraded my X1 with a 3D Touch with the firmware from Waggster (2.0) and therefore have a few questions.
First of all, thank you very much for the made effort of completing such a firmware. Everything worked wonderfully with the instructions. Great!
I tried to install a BL Touch, because the X1 is almost every time in the Z Offset again different and you can not get good print results. Leveling. That's why I did the conversion. However, I still have the same problems with the BL Touch. The error seems to lie elsewhere. Have therefore ordered silicone buffers, which I will then exchange for the springs sitting on the screws of the bed. In addition, the X axis on the left side of the printer is much heavier (about 300gr), since the stepper and the board sit on this side. To compensate for the weight, I ordered round steel, which then makes the X axis on the right side just as heavy as it is on the left. Since the threaded nuts of the Z drives are loose in the threaded rods. And need to drop down freely to get an even Z height, I decided to do this.
Let's see if I get better repeatability then.
Here are my questions!

1. when I do the Z offset the first time, it is with cold bed and cold nozzle. I therefore assume that the settings for both in the heated state also correct?  After 2 times down press at the Babysteps but then the distance to the bed is much too small. If I leave the Z height after leveling with a sheet of paper as it was without 2x to press the down button, then the Z offset fit even with hot bed and Nozzle.
So what is the point of pressing the down button 2x.

2. does pressing the EEPROM delete button delete all data in the EEPROM? If so, then my determined steps for the motor calibrations and PID tuning values are all gone?

4. if I have done the autoleveling, is that saved as meshleveling and automatically compensates for unevenness of the print bed?

5. should I definitely run autolevel in startup Gcode G29, or does it not have to be?

6. when setting up the print bed again (mechanically), you can only level manually (printer off) to see if the print plate is not too crooked. But this is very tedious. Is there another way to do this? Normal leveling in the menu with 4 level points at the corners of the print bed?

7. is the Marlin firmware 2.0 in the folder Marlin-bugfix-2.0.x BLTouch and baby complete so that I could enter my steps and PID values directly there. And then compile?

8. i made a test print. Procedure, according to Waggster instruction, up to the point Autoleveling in the menu of the printer. Then started the test print G code. I pressed up 8 more times during the print as described with the babysteps to get a good nozzle height at the beginning. The result does not look like auto meshleveling is taking place.

How can i include pics?

9. what did I do wrong?


Greetings from Germany
Doc
(may the spook end soon)


Translated with www.DeepL.com/Translator (free version)