Author Topic: Can't Keep Nozzle From Smashing Into Bed  (Read 169 times)

01Time

  • Newbie
  • *
  • Posts: 1
    • View Profile
Can't Keep Nozzle From Smashing Into Bed
« on: February 18, 2022, 11:53:42 PM »
I don't know where to begin...I have an Artillery Sidewinder X1 and I decided to do some upgrades, to include the BL Touch. After I installed the new hardware, I flashed new firmware (board and display) and followed the instructions on how to configure the BL Touch. But no matter what I do, the nozzle pushes into the bed until I kill the power (video: https://youtu.be/u14nnxdQOQU). I've been assuming it is a firmware setting, but now I'm thinking it's hardware related since no matter the firmware I get the same result.

Attempting to solve the problem and assuming it was a firmware setting, I've tried various firmware. Including the factory firmware from Artillery's GitHub (https://github.com/artillery3d/sidewinder-x1-firmware), multiple variants of Digant's (https://github.com/digant73/Artillery-Sidewinder-X1_releases_main_board/tree/master/artillery_swx1_marlin_fw_2.0.9.1), and of course, Waggster's (https://3duk.co.uk/index.php?action=downloads;sa=view;down=9). But none have made a difference. I'm at a loss...I've double checked the wiring and I've even re-flashed the board's bootloader. I did make other hardware changes at the time I added the BL Touch; an E3D v6 hotend, a BondTech BMG extruder, and I swapped the rollers for polycarbonate.

Could I have inadvertently damaged hardware during one the installs that's causing this behaviour?

To verify I am not overlooking something obvious, here are some photos of the modified wiring (btw, the black wire from the BL Touch that is unnecessary goes to a vacant pin on the board - it's just in the same Dupont receptacle to keep it out of the way):



« Last Edit: February 19, 2022, 12:48:21 PM by 01Time »